PhilC Designs :: View topic - Scissors crashing


 

 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
  Plug-ins, Content & Tutorials for Poser
Scissors crashing
Goto page Previous  1, 2
 
Post new topic   Reply to topic    PhilC Designs Forum Index -> Clothing Designer Modules
View previous topic :: View next topic  
Author Message
Thalek



Joined: 05 Mar 2008
Posts: 31

PostPosted: Wed Jan 30, 2013 11:24 pm    Post subject: Reply with quote

Wow! That didn't take long! Thank you.

I've responded in email.
Back to top
View user's profile Send private message
Thalek



Joined: 05 Mar 2008
Posts: 31

PostPosted: Thu Jan 31, 2013 10:20 am    Post subject: Reply with quote

Sorry I didn't get back to you last night.

I tried out the update this morning and it did the trick!

Thanks again, Phil, for your help.
Back to top
View user's profile Send private message
PhilC
Site Admin


Joined: 23 Aug 2005
Posts: 4553
Location: Lawrenceburg Kentucky

PostPosted: Thu Jan 31, 2013 1:40 pm    Post subject: Reply with quote

Sorry it took so long getting to the final solution. I think there is something in SR3 that made it go wobbly.
_________________
Back to top
View user's profile Send private message Send e-mail Visit poster's website Yahoo Messenger MSN Messenger
Thalek



Joined: 05 Mar 2008
Posts: 31

PostPosted: Thu Jan 31, 2013 2:32 pm    Post subject: Reply with quote

I'm inclined to agree. I'm not sure why it worked that one time, unless I accidentally loaded 2010 instead of 2012. But it's working all the time now, and working properly, and I have you to thank for that.

And I do.
Back to top
View user's profile Send private message
CTStump



Joined: 11 Apr 2014
Posts: 2
Location: United States

PostPosted: Sat Apr 12, 2014 7:19 am    Post subject: Re: Still crashing Reply with quote

jackgerber wrote:
I downloaded and installed th update and just tired to use it. This time Poser didn't crash (which I appreciate) but I got this error message:

Traceback (most recent call last):
File "C:\Poser\Poser 9\Runtime\Python\poserScripts\PhilC\Scissors\temp\temp.py", line 37, in <module>
scissors.performCut()
File "C:\Program Files\Smith Micro\Poser Pro 2012\Runtime\Python\poserScripts\PhilC\Scissors\scissors.py", line 115, in performCut
File "C:\Program Files\Smith Micro\Poser Pro 2012\Runtime\Python\poserScripts\PhilC\Scissors\scissors.py", line 986, in exportImport
UnicodeDecodeError: 'utf8' codec can't decode byte 0xe8 in position 0: invalid continuation byte

Can you tell me what it means?


Dear Phil

I just updated Clothing designer to run on Poser 9(SR3) and I'm getting this same error, it keeps referring to Poser Pro 2012 which I don't have.

I notice that you have sent others in this thread a fix but you don't explain what the problem is.

Could you please elaborate what this problem is and if possible provide a solution?

Thanx in advance
Back to top
View user's profile Send private message Send e-mail AIM Address
PhilC
Site Admin


Joined: 23 Aug 2005
Posts: 4553
Location: Lawrenceburg Kentucky

PostPosted: Mon Apr 14, 2014 1:02 am    Post subject: Reply with quote

Can you please let me know the Scissors version number. You can see this by running the script and clicking the "Version" button.

Then if you could please set up the scene again and save it at the point just prior to making the cut and send me the PZ3 file. There may be something in the geometry that the script does not like.

Thanks.
_________________
Back to top
View user's profile Send private message Send e-mail Visit poster's website Yahoo Messenger MSN Messenger
CTStump



Joined: 11 Apr 2014
Posts: 2
Location: United States

PostPosted: Mon Apr 14, 2014 1:36 am    Post subject: Reply with quote

PhilC wrote:
Can you please let me know the Scissors version number. You can see this by running the script and clicking the "Version" button.

Then if you could please set up the scene again and save it at the point just prior to making the cut and send me the PZ3 file. There may be something in the geometry that the script does not like.

Thanks.


Files and email sent, I haven't checked OBJ2CR2 yet but hopefully it wont be an issue.

Thank's
Back to top
View user's profile Send private message Send e-mail AIM Address
PhilC
Site Admin


Joined: 23 Aug 2005
Posts: 4553
Location: Lawrenceburg Kentucky

PostPosted: Mon Apr 14, 2014 4:26 am    Post subject: Reply with quote

Emailed reply:

Please find revised PYC file attached. Place it in Smith Micro\Poser 9\Runtime\Python\poserScripts\PhilC\Scissors so as to over write the existing.

This is what I did:-
Loaded your PZ3 however it caused Poser to crash before I got to run the script. Not every time, just sometimes. I really wish that I could tell you why but after spending quite some time on it I just drew a blank. Reboot, restart the whole nine yards. Got it to open then deleted everything from the scene that was not essential to the process. I even deleted the lights. This left me with just the dress and the cutter. I added in a basic light set up so that I could see what I was doing. Saved as Scissors_01.pz3 (attached).

Edited the script so that it would save a debug file. p9scissors.pyc attached.

Then everything worked as it should.

I wish I could tell you exactly what it was in the original file that was tripping things up. Please try the revised script, if it hiccups please send me the debug file.

Thanks
_________________
Back to top
View user's profile Send private message Send e-mail Visit poster's website Yahoo Messenger MSN Messenger
jackgerber



Joined: 06 Jan 2009
Posts: 38

PostPosted: Sat Nov 14, 2015 3:02 pm    Post subject: Scissors crashing Poser again Reply with quote

I see I have posted about this before and I know you fixed it so I am hoping you can fix it again. I am now using Poser Pro 2014 (and will be upgrading to Poser 11 soon) and I tried to use Scissors and it crashed Poser. To check this I restarted Poser, loaded in a primitive cone and then the front cutter. I selected the cone and tried to cut and Poser crashed. I did nothing else. I thought I was using the latest version as far as I know.

Any suggestions?
Back to top
View user's profile Send private message Send e-mail
PhilC
Site Admin


Joined: 23 Aug 2005
Posts: 4553
Location: Lawrenceburg Kentucky

PostPosted: Mon Nov 16, 2015 8:25 am    Post subject: Reply with quote

Links to updated files sent.
_________________
Back to top
View user's profile Send private message Send e-mail Visit poster's website Yahoo Messenger MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic    PhilC Designs Forum Index -> Clothing Designer Modules All times are GMT - 5 Hours
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Forum software by p h p B_B © 2001, 2005 p h p_B B Gr0up